Неустранимая ошибка: Uncaught PHPExcel_Calculation_Exception

Я пытаюсь прочитать XML-файл с PHP, но у меня есть некоторые проблемы.

Прежде всего, если моя ячейка: 20/11/2016, я получаю это на PHP с getFormattedValue() , но ее результат: 42370. Почему?

И другое и более важно то, что я хочу результат в ячейке формулы: например, я имею в ячейке: 128, но формула:

 =SI(O(INDICE(Precios;COINCIDIR(C$1;Tipos;0);COINCIDIR($A326;Días;0))="";INDICE(Precios;COINCIDIR(C$1;Tipos;0);COINCIDIR($A326;Días;0))=Caracter_Cierre);"";MAX(INDICE(Precios;COINCIDIR(C$1;Tipos;0);COINCIDIR($A326;Días;0));INDICE(Precios_Minimos;COINCIDIR(C$1;Tipos_Precios_Minimos;0);3))) 

Итак, я получаю это с помощью: getCalculatedValue() но потом я получил такую ​​ошибку:

Неустранимая ошибка: Uncaught PHPExcel_Calculation_Exception: Tesipro! C2 -> Ошибка формулы:

Я не знаю, что делать.

Прежде всего, если моя ячейка: 20/11/2016, я получаю это в php с getFormattedValue (), но ее результат: 42370. Почему это?

42370 – это временная метка MS Excel. Внутренне MS Excel поддерживает даты / время как числовую метку времени; плавающее значение, удерживающее количество дней с 1 января 1900 года (или 1 января 1904 года, если версия Mac для Excel) со временем, как дробная часть дня. Затем он использует маску формата номера, чтобы отобразить это значение в удобочитаемой форме как дату.

Обычно getValue() возвращает значение необработанной ячейки, сериализованную метку времени в этом случае; и getFormattedValue() будет применять маску формата номера, чтобы преобразовать это значение в строку, отформатированную для отображения, как она отображается в графическом интерфейсе MS Excel. Если вы используете getFormattedValue() и все еще видите значение 42370 , то, по всей вероятности, вы загрузили файл с readDataOnly установленным в true, что говорит PHPExcel не загружать маски с readDataOnly форматом, поэтому он не может применять маску формата чтобы преобразовать это сериализованное значение временной метки в отображаемый формат даты.


И для проблемы с формулой я не могу много сделать, чтобы определить причину без доступа к самому файлу, проанализировать детали выполнения механизма вычисления при попытке вычислить значение; но здесь есть смысл, который показывает, как запустить вычисление в режиме отладки. Информация из этого облегчит задачу диагностики и диагностики.

  • Laravel excel maatwebsite хранит неверную ошибку дескриптора
  • Файл Yii excel не читается
  • PHP, как агрегировать 2-мерный массив
  • сгенерировать файл Excel с помощью PHP
  • Laravel export xls тип ячейки зависит от значения
  • Как я могу вставить изображение в csv или excel с помощью php
  • PHPExcel и Office 2016
  • Сделайте перенос слов. PHP для Excel
  • Почему файл Excel поврежден?
  • как читать файл разделителя табуляции в CSV, который имеет разные значения вкладок в строке?
  • проблемы с загрузкой файла Excel для импорта в базу данных cakephp
  • Давайте будем гением компьютера.